BetaArchive
https://www.betaarchive.com/forum/

Windows 95 (at least 95/98 beta's) x64 patch
https://www.betaarchive.com/forum/viewtopic.php?f=60&t=5083
Page 1 of 1

Author:  Rob Jansen [ Fri Aug 01, 2008 9:48 am ]
Post subject:  Windows 95 (at least 95/98 beta's) x64 patch

Does anyone have a link to the x64 patch to run Windows 95/98 (beta's and final) on x64 PC's in a Virtual Machine?

I also know that everyone with an x64 pc also want it.

Author:  Namronia [ Fri Aug 01, 2008 9:57 am ]
Post subject: 

That should be it ---> http://download.microsoft.com/download/ ... dk6upd.exe

Author:  Rob Jansen [ Fri Aug 01, 2008 10:10 am ]
Post subject: 

Well, didnt work

Anyone else?

Otherwise its back to my old trusty P4 x86.

Author:  The Distractor [ Fri Aug 01, 2008 10:58 am ]
Post subject: 

I know there's a P4/AMD patch for win95/98/ME around. I assume you have already tried that ? If you can't find it I might be able to upload it ..

Author:  empireum [ Fri Aug 01, 2008 11:11 am ]
Post subject: 

I had no problem running Windows 95/95b, 98 & NT4 on a 2GHz x64 CPU (Athlon 64 3000+). In fact, even NT 3.51 can run on an x64 CPU, the only version I've had problems with was WFW 3.11. I'm more inclined to believe it's due to your CPU being faster than ~2.1GHz as this is another known problem and there's a fix somewhere. Screenshots to prove (at least 98 recognizes the CPU):
Image
Image
Image

(Sorry for the German versions & comments, originally made for another forum).

Author:  Rob Jansen [ Fri Aug 01, 2008 11:24 am ]
Post subject: 

Well i get an Windows Protection error.

NTKERN and other times IOS.

I tryted the patch that namronia gave me.

My CPU = Intel Quad Core, 2.4 GHz

Author:  betamaster [ Fri Aug 01, 2008 11:53 am ]
Post subject: 

Windows 95 have problem with boot on x64 processor, and bigger problem on quad processor...

Author:  The Distractor [ Fri Aug 01, 2008 1:51 pm ]
Post subject: 

DjRob wrote:
Well i get an Windows Protection error.

NTKERN and other times IOS.

I tryted the patch that namronia gave me.

My CPU = Intel Quad Core, 2.4 GHz


Sounds like you need that P4/AMD patch that I explained about a few posts up, yup yup !

I will upload to the server.

Author:  Dion [ Fri Aug 01, 2008 3:54 pm ]
Post subject: 

Namronia wrote:

That patch is for running windows95 osr2 to 2.5 on a system running a k6 socket7 cpu
faster than 300mhz.
Years ago, amd released an update for 95 and 98 for the k7's, socket 462/socket A's,
probably the one more suited for this running old betas.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/