Mouse problem with Millennium 2348

Discuss Windows 95, 98 and ME.
Post Reply
vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Mouse problem with Millennium 2348

Post by vlad557776 »

Hello.

Recently I installed a beta build of Windows ME - build 2348, also known as Developer Release 2. I set the BIOS date, the install went normally, but, after install, I'm greeted with an hourglass icon next to my cursor. I can move the mouse, but that's basically all I can do.

My VM config is:
256 MB of RAM
1 processor
4 GB IDE hard disk
IDE CD-ROM with 2348 CD image in
Floppy drive with 98 SE bootdisk image in
Auto-detect sound card
Auto-detect display
OS set on Windows Me
ACPI disabled (was enabled, but still the same issue)

Can someone help me?
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

ATeamInc
FTP Access
Posts: 282
Joined: Sun Feb 25, 2018 6:49 pm
Location: GMT+2 w/dst
Contact:

Re: Mouse problem with Millennium 2348

Post by ATeamInc »

vlad557776 wrote:Hello.

Recently I installed a beta build of Windows ME - build 2348, also known as Developer Release 2. I set the BIOS date, the install went normally, but, after install, I'm greeted with an hourglass icon next to my cursor. I can move the mouse, but that's basically all I can do.

My VM config is:
256 MB of RAM
1 processor
4 GB IDE hard disk
IDE CD-ROM with 2348 CD image in
Floppy drive with 98 SE bootdisk image in
Auto-detect sound card
Auto-detect display
OS set on Windows Me
ACPI disabled (was enabled, but still the same issue)

Can someone help me?
I'm guessing you used VMware. You can try setting an older VM compatibility mode, like 5.x.
<!--Placeholder-->

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

I'm using Player and I have no idea how to change VM compatibility mode.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Update: I managed to boot into Safe Mode and now can troubleshoot things inside the VM. I also managed to install VMware mouse drivers, but not video drivers. Also, CD drive does not work.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

Winins
User avatar
FTP Access
Posts: 194
Joined: Wed May 29, 2019 5:36 pm
Location: Bird

Re: Mouse problem with Millennium 2348

Post by Winins »

Use 86box.
You have never seen Windows like this!
FREE Windows 3.2!
Shareware featuring an upgrade for pre-existing Windows 3.1 users and BONUS PACK
Distributed freely by PC World. March 1996

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Again... I have no experience with 86box. I'm just tired of people saying "Use PCem" or something like that.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

AlphaBeta
User avatar
Donator
Posts: 2137
Joined: Sun Aug 12, 2012 4:33 pm
Location: Czechia

Re: Mouse problem with Millennium 2348

Post by AlphaBeta »

Well, then perhaps this is the occasion to learn how to use 86Box? You shouldn't expect that everything will be served to you on a golden plate.
AlphaBeta, stop brainwashing me immediately!

Image

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Oh. I think I'll try PCem first.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Okay, I installed it on PCem. Are there any video drivers available for PCem? There are some VMware SVGA drivers I found on Rob's site, they work perfectly with almost any OS that is installed on VMware products.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

Overdoze
User avatar
FTP Access
Posts: 1694
Joined: Mon Feb 24, 2014 10:28 am
Location: Slovenia

Re: Mouse problem with Millennium 2348

Post by Overdoze »

Depends on the display adapter you configured in PCem.
All roads lead to Neptune™

KRNL386 - my site about retro computing | My site about Windows 1.0 | My blog | 86Box Manager | LeakDB - list of PC OS warez leaks

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

I set the standard VGA. I tried Voodoo and 9x drivers, but it gave me the same result as standard VGA.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

AlphaBeta
User avatar
Donator
Posts: 2137
Joined: Sun Aug 12, 2012 4:33 pm
Location: Czechia

Re: Mouse problem with Millennium 2348

Post by AlphaBeta »

Well VGA is just standard 640x480 at 16 colors, you won't get anything better than that with it. Try a Trio64.
AlphaBeta, stop brainwashing me immediately!

Image

MCpillager12
User avatar
Posts: 361
Joined: Wed Apr 17, 2019 12:44 pm
Location: Russia
Contact:

Re: Mouse problem with Millennium 2348

Post by MCpillager12 »

vlad557776 wrote:I set the standard VGA. I tried Voodoo and 9x drivers, but it gave me the same result as standard VGA.
Use theS3 Trio64 or an Nvidia card.
If youre at 480p/16c with nvidia card use the 98SE drivers.
Help!!!! hOw DO I run WiNdoWS 8 vM wIThouT vm soFtWarE???

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Well, I tried S3 Trio64 and some 9x/ME drivers I found. But all drivers are returning error code 20E.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

tarquin44
Posts: 55
Joined: Wed May 22, 2019 3:36 pm

Re: Mouse problem with Millennium 2348

Post by tarquin44 »

If you're uncomfortable with PCem/86box, 2348 installs easily in Virtualbox using the "scitech-display-doctor-7" 32-bit true colour drivers.

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

Okay, I think I had some VBox stuff laying in my folders.
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

vlad557776
Posts: 173
Joined: Sun Apr 28, 2019 10:11 am

Re: Mouse problem with Millennium 2348

Post by vlad557776 »

The SciTech Display Doctor drivers worked. Needed to dive into the configuration to make these work on 32-bit colours, but still good. And I even used another version of SciTech Display Doctor on OS/2 earlier. Thanks!
The developer of Win1 Packet - https://www.betaarchive.com/forum/viewt ... 59&t=40233
The developer of IM1024 INSTALL.BAT Patch: https://www.betaarchive.com/forum/viewt ... 59&t=40317

tarquin44
Posts: 55
Joined: Wed May 22, 2019 3:36 pm

Re: Mouse problem with Millennium 2348

Post by tarquin44 »

vlad557776 wrote:The SciTech Display Doctor drivers worked. Needed to dive into the configuration to make these work on 32-bit colours, but still good. And I even used another version of SciTech Display Doctor on OS/2 earlier. Thanks!
You're welcome.

Post Reply