BetaArchive Logo
Navigation Home Screenshots Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 0d, 13h, 32m | CPU: 24% | MEM: 1928MB of 2985MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 16 posts ] 
Author Message
 PostPost subject: Windows 98 SE setup throws errors at the end of setup        Posted: Wed Jun 27, 2018 11:11 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
I've been having a problem installing Windows 98 SE on VMWare 14.
No matter which ISO I try, no matter in which language, when I get to the very last part of setup (the "Installing Windows 98" dialog with the drumroll animation), various applications start throwing errors. Most of them are illegal operations, while others are about DLLs which fail to load/being missing or damaged. There are so many and from so many different applications/DLLs that I'm pretty sure it's an issue with virtualization, but the strange thing is, until not much time ago all of this wasn't happening.
Plus, even if I skip all of the errors (which involves a lot of clicking), when booting into Windows, Explorer immediately throws an illegal operation and crashes. So it's an issue that needs to be resolved.

The VM is configured to use 256MB of RAM and an 8GB IDE HDD. I've already tried to lower the RAM to 32MB, with no success. I would've also tried to disable virtualization, but I can't seem to find that option.

The last thing I have to say is that Windows ME installs just fine

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Wed Jun 27, 2018 11:17 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Nov 22, 2017 5:39 pm

Posts
100

Location
Somewhere in PCem

Favourite OS
Whistler 2428 and Longhorn 3718
PCem and 86Box can run Windows 9x at a more stabler condition than virtualizers like Virtualbox and VMware can. Try installing Windows 98 SE on there. Also, try using compatibility mode for older versions of VMware if that will work.

_________________
Image

The one who finds the best out of regular PCem.


Top  Profile  WWW
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 8:29 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Fri Apr 25, 2014 5:37 pm

Posts
437

Location
Poland

Favourite OS
3.11 WfW, 98SE, 5.1.2464, LH4001
Broken iso, I've never had any problems with 98SE on VMware.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 12:44 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
oscareczek wrote:
Broken iso, I've never had any problems with 98SE on VMware.

I tried at least three different ISOs

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 8:25 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
BF10 wrote:
PCem and 86Box can run Windows 9x at a more stabler condition than virtualizers like Virtualbox and VMware can. Try installing Windows 98 SE on there. Also, try using compatibility mode for older versions of VMware if that will work.

My PC is too shitty to run 98SE with audio and everything at full speed. Plus, I really wanted it on a VM, due to all the advantages of the VMWare tools

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 9:24 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Wed Feb 23, 2011 12:11 am

Posts
3388

Location
Italy

Favourite OS
Windows, OS/2, DOS
Except that ram usage under 86Box has been reduced greatly.

_________________
http://forum.softhistory.org


Top  Profile  WWW
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 10:57 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
TheCollector1988 wrote:
Except that ram usage under 86Box has been reduced greatly.

It's not RAM usage, it's my CPU being too slow

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Thu Jun 28, 2018 11:53 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Jan 23, 2012 2:48 pm

Posts
294

Location
guess it

Favourite OS
whistler2296
I just tested with VMware Workstation 14.1.2 and 98SE installation completes fine for both 14.x and 6.5-7.x compatibility. Guest OS selected as Windows 98, chose "I will install the operating system later" when it asked for the CD image upon VM setup. RAM size 512 MB, hard disk 12 GB IDE.

Image being used was 4.10.2222a_x86fre_client_en-us-Win98 SE.iso, did use a separate 98SE boot floppy image and fdisk to create partition then format. Did not install MS-DOS, just ran setup.exe directly after getting into DOS with the boot floppy.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jun 30, 2018 8:28 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sun Mar 16, 2014 6:56 am

Posts
144

Favourite OS
DOS
Zacchi4k wrote:
Plus, I really wanted it on a VM, due to all the advantages of the VMWare tools


I have a feeling/seem to recall that some parts of VMware Tools don't work with Windows 9x.

I've only run Windows 95 on VMware (Player, in my case), in which case I followed the instructions at https://communities.vmware.com/thread/486727 to downgrade the virtual hardware version to get audio support. Perhaps similar changes are required to address your problems? Just speculating.

PlyrStar93 wrote:
I just tested with VMware Workstation 14.1.2 and 98SE installation completes fine for both 14.x and 6.5-7.x compatibility. Guest OS selected as Windows 98, chose "I will install the operating system later" when it asked for the CD image upon VM setup. RAM size 512 MB, hard disk 12 GB IDE.


Did you happen to get audio working?


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jun 30, 2018 8:48 am 
Reply with quote
FTP Access
Offline

Joined
Sun Feb 25, 2018 6:49 pm

Posts
97

Location
Somewhere in your computer...

Favourite OS
5.01.2419
DOS wrote:
Did you happen to get audio working?


Well you can get the audio working. Search for the SoundBlaster PCI 128 drivers for Windows 9x or NT.

_________________
No comment.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jun 30, 2018 12:53 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
Just to be sure, I tried installing 98SE with the same ISO on 86Box, and it didn't throw any errors, which means it's an issue with VMware, I just don't get what it is. Plus, the fact I was able to succesfully install 95C as a VM (except for the Windows Protection Error, for which I used FIX95CPU) really leaves me wondering why won't 98SE work

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jun 30, 2018 2:31 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
DOS wrote:
Zacchi4k wrote:
Plus, I really wanted it on a VM, due to all the advantages of the VMWare tools


I have a feeling/seem to recall that some parts of VMware Tools don't work with Windows 9x.


The parts I care about all work: mouse integration, automatic resolution, and drag and drop support

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jun 30, 2018 3:41 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Jan 23, 2012 2:48 pm

Posts
294

Location
guess it

Favourite OS
whistler2296
DOS wrote:
Did you happen to get audio working?

Audio working for both 6.5-7.x and 14 compatibility, pretty much what ATeamInc said but the SBPCI128 driver I used was SBPCI_WebDrvsV5_12_01.exe. VM will enter CPU shutdown state (and driver doesn't work) if I use the one found from Creative's website (SBPCI128Setupus_w9x.exe).

I think an alternative is to modify the .vmx file to set the audio device to sb16 and Windows 98 would detect it when you scan for hardware change next time (and the driver can be installed from Windows 98 CD), but the sound quality would be worse. At least this is how I get sound to work in a Windows 95 guest.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sat Jul 07, 2018 5:18 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
I've tried downgrading to VMware 12.1.1, and this time, Windows 98SE installed without any errors. Next thing I'm going to do is try upgrading back to VMware 14 and see if the VM breaks again

EDIT: Apparently other people too are having the same problem:
https://communities.vmware.com/thread/579537
https://communities.vmware.com/thread/578907
https://communities.vmware.com/thread/574759

Looks like the common issue is the AMD CPU along with VMware 14

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Last edited by Zacchi4k on Sun Jul 08, 2018 11:35 pm, edited 1 time in total.

Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Sun Jul 08, 2018 11:02 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Aug 18, 2014 10:47 pm

Posts
212

Location
Italy

Favourite OS
Windows XP
Aaaaaand... it broke again.

PlyrStar93 wrote:
I just tested with VMware Workstation 14.1.2 and 98SE installation completes fine for both 14.x and 6.5-7.x compatibility. Guest OS selected as Windows 98, chose "I will install the operating system later" when it asked for the CD image upon VM setup. RAM size 512 MB, hard disk 12 GB IDE.

Image being used was 4.10.2222a_x86fre_client_en-us-Win98 SE.iso, did use a separate 98SE boot floppy image and fdisk to create partition then format. Did not install MS-DOS, just ran setup.exe directly after getting into DOS with the boot floppy.

Could you send me your .vmx file?

_________________
Greifi Grishnackh wrote:
There are more mistakes in two lines of Ubuntu's code than in Windows since version 3.1 to today.


Top  Profile
 PostPost subject: Re: Windows 98 SE setup throws errors at the end of setup        Posted: Mon Jul 09, 2018 7:53 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Jan 23, 2012 2:48 pm

Posts
294

Location
guess it

Favourite OS
whistler2296
Zacchi4k wrote:
Aaaaaand... it broke again.

Could you send me your .vmx file?

Just uploaded the two versions of .vmx to Dropbox. One is with 6.5-7.x compatibility and the other is 14. I also copied the VM (14 compatibility) from the computer I created them to my laptop and tried booting up, it gave me a BSOD first but then I was able to boot into safe mode and subsequently I could get into regular mode without BSOD.

As for the .vmx, doesn't look like there is anything remarkable, all code was generated automatically by VMware, didn't edit anything manually.
https://www.dropbox.com/s/jomth0y89g8r1hg/win98-vm-ba.zip?dl=0


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2018

 

Sitemap | XML | RSS