BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 67d, 0h, 52m | CPU: 11% | MEM: 5418MB of 12287MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 19 posts ] 
Author Message
 PostPost subject: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 4:30 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Hello everybody!

So I was testing my Windows 95 Upgrade CD to see which build number it was (4.00.950 when I went to Safe Mode), and I was installing it like any of us would. It finished the stage of the installation where it would tell you all the "greatest" and "newest" features of Windows 95. After it rebooted, I was greeted with the Startup Splash Screen, followed a couple of seconds later by the "Windows Protection Error". Now before installing Windows 95, I have had MS-DOS 6.22 installed, with a CD/DVD driver installed (from a website I found). I had to install the CD-ROM driver because MS-DOS 6.22 does not natively support CD-ROM drives 'for whatever reason'. I have (atleast I think I have) removed the autoexec.bat lines for the CD-ROM driver to be loaded, but no success. I am using VMWare Workstation 12. Should I switch to VirtualBox, or is there something I should try out.

ImageImage

Thank you!


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 2:02 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
Switching to VirtualBox won't help as it's still a virtualizer so it will still cause the same error if your host CPU's speed is too fast for Windows 95.

I really recommend PCem instead. Use http://goo.gl/JYoP4k , it has everything you need.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 3:57 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
Switching to VirtualBox won't help as it's still a virtualizer so it will still cause the same error if your host CPU's speed is too fast for Windows 95.

I really recommend PCem instead. Use http://goo.gl/JYoP4k , it has everything you need.


Thank you sir! I will try this for sure! If it all works out, I'll reply back! :OD :D :D


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 5:02 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Ok, so I'm having a small issue with PCem. I've *suprisingly* figure out how to get the hard drive to be set up, but now I ran into a issue. My Windows 98SE CD (which would usually be bootable from most systems, including my Pentium 3 board, i was going to test Windows 98 to see how well PCem would perform)) is not bootable from the BIOs. I would get a message like "DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER." I've tried using other Windows CDs that I know would have booted from, but no success. Anything I should try?


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 5:03 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Fri Apr 25, 2014 5:37 pm

Posts
517

Location
Poland

Favourite OS
3.11 WfW, 98SE, 5.1.2464, LH4001
bootdisk.com and download 98SE floppy with CD support


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 5:27 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
- DescentGuy195: Make sure to use a board that can boot from CD such as the ASUS P55-TP4XE or Award 430VX PCI and that CMOS Setup is correctly configured too.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 5:56 pm 
Reply with quote
FTP Access
Offline

Joined
Sun Sep 08, 2013 8:56 pm

Posts
467
Battler wrote:
- DescentGuy195: Make sure to use a board that can boot from CD such as the ASUS P55-TP4XE or Award 430VX PCI and that CMOS Setup is correctly configured too.


Or the Epox board, whatever the model number was.

_________________
86Box Power User & Configuration Tester
Now known as DDX on most places on the Internet.


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 6:07 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
- DescentGuy195: Make sure to use a board that can boot from CD such as the ASUS P55-TP4XE or Award 430VX PCI and that CMOS Setup is correctly configured too.


Wow! Didn't think I would be such an IDIOT to forget to check the CMOS! I never set up the CMOS to boot from the CD-ROM. Now it does! Thanks for making me find my own mistakes! I am a bit of a nooby with older motherboards that don't automatically have the CMOS set to boot from CD-ROM (my Intel 440BX board booted from the CD ROM automatically when I first set it up, lol)

:) Thanks everyone!


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 6:30 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
And now, there's more problems. Man do old operating systems hate me. So I got into the 98 set up and went through it as usual, formating the drive, restarting, going into set up. As soon as I choose my directory however, I'm greeted with this: Image
Here are my machine settings. Anything else that I'm missing? I've checked the CMOS settings up and down to see if there's anything there that I missed.
Image


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 7:30 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
Use a Pentium board such as Award 430VX PCI or ASUS P55-TP4XE, it's good enough for Windows 98. The emulation of the two Pentium II boards and Pentium II themselves is incomplete right now, so stay away from it for time being. :p
I recommend the ASUS P55-TP4XE and something like a Pentium 120 at most for the smoothest emulation, or if you really need i686, ASUS P55-T2P4 and a Cyrilic 6x86MX CPU.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 7:57 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
Use a Pentium board such as Award 430VX PCI or ASUS P55-TP4XE, it's good enough for Windows 98. The emulation of the two Pentium II boards and Pentium II themselves is incomplete right now, so stay away from it for time being. :p
I recommend the ASUS P55-TP4XE and something like a Pentium 120 at most for the smoothest emulation, or if you really need i686, ASUS P55-T2P4 and a Cyrilic 6x86MX CPU.


I've switched to the Award 430VX PCI (and to a Pentium 120), and I'm still getting the MS-DOS Extender Fault Error. There's 64MB of RAM I set to it. Settings are mostly the same other then the Machine, CPU, and RAM... I almost want to call GG at this moment.


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 10:07 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
Then you've found a bug. I'm going to look into it and see why it's happening.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 10:33 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
Then you've found a bug. I'm going to look into it and see why it's happening.


Thank you!


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 11:43 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
OK, I think I fixed it. Replace your PCem.exe with: http://citadel.ringoflightning.net/PCem.exe .

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Sun May 01, 2016 11:46 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
OK, I think I fixed it. Replace your PCem.exe with: http://citadel.ringoflightning.net/PCem.exe .


You've seemed to fix it! It didn't instant-crash as soon as I clicked next. What seemed to be the mishap in the programming? You should probably release that as a patch so people who are new to PCem don't deal with the same issue.


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Mon May 02, 2016 12:41 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
When I added the checking for the present bit of a segment in protected me on reads and writes within a segment, I forgot to update the part where a null segment was being loaded - it was not turning on the present bit, which was causing your problem. Now the present bit is correctly set when loading a null non-code segment.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Mon May 02, 2016 12:46 am 
Reply with quote
User avatar
Offline

Joined
Mon May 02, 2016 12:18 am

Posts
10

Location
The United States of America

Favourite OS
Windows 95
I have installed Windows 95 in Virtualbox. The trick is look to see if hardware acceleration is off because it cannot be turned on. This may be the same thing in VMWare but, I am not too knowledgeable when it comes to that program.

_________________
Subscribe To MS-GIL on YouTube for computing videos and tutorials :)
Image


Top  Profile  WWW
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Mon May 02, 2016 12:58 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Sat Apr 30, 2016 8:54 pm

Posts
19

Favourite OS
Windows 98 SE 4.10.2222
Battler wrote:
When I added the checking for the present bit of a segment in protected me on reads and writes within a segment, I forgot to update the part where a null segment was being loaded - it was not turning on the present bit, which was causing your problem. Now the present bit is correctly set when loading a null non-code segment.

Neat. Well atleast it's all fixed now! And now I'm running Windows 98 without a hitch! Thanks again!


Top  Profile
 PostPost subject: Re: "Windows Protection Error" after rebooting from install        Posted: Mon May 02, 2016 2:08 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2017

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
- MS-GIL: It also strongly depends on your host CPU speed.

- DescentGuy195: The thanks goes to you for finding and reporting the bug. :p

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2020

 

Sitemap | XML | RSS