BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 79d, 2h, 20m | CPU: 72% | MEM: 6572MB of 12287MB used
{The community for beta collectors}

Forum rules


Any off topic discussions should go in this forum. Post count is not increased by posting here.
FTP Access status is required to post in this forum. Find out how to get it


Post new topic Reply to topic  [ 5 posts ] 
Author Message
 PostPost subject: Sound in Windows 7 Build 7100 on VPC 2007 SP1        Posted: Sun Jul 19, 2009 5:02 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Jun 14, 2008 11:30 am

Posts
1206

Location
In the Floating island above the sky

Favourite OS
Windows NT 3.1 Build 297
Windows 7 can recognize the Virtual Machine Additions from VPC 2007 SP1. Sound are absent after installing VPC Additions in Windows 7. Can you find the solution? I've running the virtual Windows 7 on Windows XP SP2, 1GB ram (512MB memory used, slower).

_________________
Online periodically.
---
M$ Software Labels | OS Tester | Software Geek | Creative Agent!

Last edited by trustBA on Mon, 3rd Nov, 2013 6:99 am, edited 100 times in total.


Top  Profile  WWW
 PostPost subject: Re: Sound in Windows 7 Build 7100 on VPC 2007 SP1        Posted: Sun Jul 19, 2009 9:10 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat May 12, 2007 1:05 pm

Posts
5271

Location
The Collection Book

Favourite OS
Windows & Phone
trustBA wrote:
Windows 7 can recognize the Virtual Machine Additions from VPC 2007 SP1. Sound are absent after installing VPC Additions in Windows 7. Can you find the solution? I've running the virtual Windows 7 on Windows XP SP2, 1GB ram (512MB memory used, slower).


That is because of the sound driver.
Windows Vista and 7 never had good support for it.

What kind of VM did you select?
If it isn't Vista but something else, you can end up with Soundblaster 16, which is a ISA card and has been removed from support with Windows Vista.

You are probably better of with VMWare.

Offtopic Comment
[rant]Why does everybody use, prolly instead of probably?[/rant] Please do not quote or discuss this offtopic in this topic!

_________________
Image
http://www.thecollectionbook.info
Subscribe to our Image for updates and like us on Image.

Reading Mode only, PM's possible.


Top  Profile  WWW
 PostPost subject: Re: Sound in Windows 7 Build 7100 on VPC 2007 SP1        Posted: Sun Jul 19, 2009 10:11 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Jun 14, 2008 11:30 am

Posts
1206

Location
In the Floating island above the sky

Favourite OS
Windows NT 3.1 Build 297
Well I've posted here, but not me, the other user:

http://social.technet.microsoft.com/For ... 0b60443b69
http://www.computing.net/answers/window ... 72500.html

Edit: Sound working in Windows 7 in VPC 2007 SP1 in XP SP2.

1. Mount the VMAdditions.iso and choose the folder icon to explore the directory.
2. Go to the Windows folder and right click the VirtualMachineAdditions.msi and choose Troubleshooot Compatibility. (or right click the VirtualMachineAdditions.msi and choose Properties. Go to Compatibility tab, and tick the Run this program in compatibility mode for:. Select "Previous version of Windows" (Or "Windows Vista" in older builds) and then click OK.
3. Install, restart, and then, you have the sound in Windows 7.

Look here:

Image

_________________
Online periodically.
---
M$ Software Labels | OS Tester | Software Geek | Creative Agent!

Last edited by trustBA on Mon, 3rd Nov, 2013 6:99 am, edited 100 times in total.


Top  Profile  WWW
 PostPost subject: Re: Sound in Windows 7 Build 7100 on VPC 2007 SP1        Posted: Sun Jul 19, 2009 3:38 pm 
Reply with quote
Donator
Offline

Joined
Thu Nov 08, 2007 6:08 am

Posts
819

Location
Malaysia
DjRob wrote:
That is because of the sound driver.
Windows Vista and 7 never had good support for it.

What kind of VM did you select?
If it isn't Vista but something else, you can end up with Soundblaster 16, which is a ISA card and has been removed from support with Windows Vista.

Really? I have sound for both Windows Vista and Windows 7 running inside Virtual PC 2007 SP1. Hmmm...

_________________
Image


Top  Profile  WWW  YIM
 PostPost subject: Re: Sound in Windows 7 Build 7100 on VPC 2007 SP1        Posted: Sun Jul 19, 2009 9:14 pm 
Reply with quote
FTP Access
Offline

Joined
Mon Jul 13, 2009 10:28 pm

Posts
47

Favourite OS
XP
I'm currently using Sun VirtualBox for Windows 7 7100 and the sound works perfectly after you install the guest additions.


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 




Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2019

 

Sitemap | XML | RSS