What was your first beta?

Any off topic discussions should go in this forum. Post count is not increased by posting here.
FTP Access status is required to post in this forum. Find out how to get it
Forum rules
Any off topic discussions should go in this forum. Post count is not increased by posting here.
FTP Access status is required to post in this forum. Find out how to get it
Post Reply
WinPC

What was your first beta?

Post by WinPC »

--------
Last edited by WinPC on Thu Feb 21, 2013 5:49 am, edited 1 time in total.

UltimateGTR
Donator
Posts: 772
Joined: Thu Dec 06, 2007 2:55 pm

Post by UltimateGTR »

I do not know what is beta when I start to collect software, and I am interesting in it.

My first beta version of Microsoft Windows is Windows Longhorn Build 5048, I think it is release in Aug. 2005, I installed it and love it, and I start to collect beta version of software. My friends in Macau always believe me I am the 1st one to use a software when something new is released....The people who love computer and software is very few in Macau. After I try a new beta or final version of new software, I would report to my friends who are interesting in computers, just like providing feedback.

PS : Macau is near Hong Kong, is a part China.

Unknown

Re: What was your first beta?

Post by Unknown »

My 1st was 73g.
WinPC wrote: Unfortunatly I would sometimes confuse BetaArchive with OSBetaArchive .
Not sure how you'd do that, BetaArchive started up a little after
OSbetaarchive closed down, they were never up at the same time AFAIK.

mdogg
User avatar
Donator
Posts: 954
Joined: Fri May 18, 2007 9:39 am
Location: My house

Post by mdogg »

My first beta I tried was Neptune 5111 on an old Pentium MMX box. It works quite well considering Neptune is more "new generation" (500MHz to 1GHz) with 30 seconds for boot up (including BIOS screens).
Image

Namronia

Post by Namronia »

my was vista 5231

ive installed it at my best friend, after that he hates me

hounsell

Post by hounsell »

Mine was the Public Vista Beta 2 & RC1. After that, i liked the betas, but wanted to try earlier builds, and i found out about 4074 after a bit of searching. This then lead me to JoeJoe, where I found out about this site

empireum
Donator
Posts: 3557
Joined: Sat Sep 30, 2006 5:00 pm

Post by empireum »

Mine was Windows 2000 beta 3, back in 1999.

Jeff
User avatar
Donator
Posts: 1004
Joined: Mon Sep 04, 2006 1:06 pm
Location: USA

Post by Jeff »

My first beta was the first longhorn that was leaked.
-Jeff

Raiker
FTP Access
Posts: 419
Joined: Tue Aug 28, 2007 11:18 pm
Contact:

Post by Raiker »

It was 4074, my first beta, I tried it summer 2004.
Quod licet Jovi, non licet bovi

Dr Eggman
User avatar
FTP Access
Posts: 321
Joined: Sat Jun 30, 2007 8:25 pm
Location: Eggmanland/Toronto
Contact:

Post by Dr Eggman »

Can't remember what year, but my friend who lives next door told me about Vista. Then i went to a torrent site and downloaded LH4074 and then Vista Beta 2 from the M$ site, RC1, RC2 etc. Then, i came here and found out about Whistler, Chicago, Longhorn etc. Since then, i have been an active member in the beta community.
I am The Eggman! -The Doctor
Like Pictures? Bored? Check out some Photography and "Like" it! Check it out here!

euformi

Post by euformi »

My first beta is Longhorn 4008

WinPC

Post by WinPC »

Not sure how you'd do that, BetaArchive started up a little after
OSbetaarchive closed down, they were never up at the same time AFAIK
Sometimes I would go to www.osbetaarchive.com and instead of seeing OSBetaArchive I would see "Liam Bramwell Dot-com".

Kenneth
Donator
Posts: 2407
Joined: Sun May 13, 2007 12:42 am

Post by Kenneth »

Windows Longhorn 4051 Repack by MsTest?

Andy
User avatar
Administrator
Posts: 12621
Joined: Fri Aug 18, 2006 11:47 am
Location: United Kingdom
Contact:

Post by Andy »

WinPC wrote:
Not sure how you'd do that, BetaArchive started up a little after
OSbetaarchive closed down, they were never up at the same time AFAIK
Sometimes I would go to www.osbetaarchive.com and instead of seeing OSBetaArchive I would see "Liam Bramwell Dot-com".
Thats because Liam Bramwell owns the domain and pointed it to his own site, probably in order to get traffic.

XDude
Donator
Posts: 1518
Joined: Fri Dec 29, 2006 6:40 am

Post by XDude »

Longhorn for me. I believe it was 4053 or 4074. Then I tried most of the early longhorn builds whixh was intresting because of the eye candies.

Peteski
User avatar
FTP Access
Posts: 85
Joined: Fri Jun 08, 2007 1:49 pm
Location: Halifax, UK
Contact:

Post by Peteski »

longhorn 4051, i had no idea what i was doing. it was on the list of popular torrents so i thought what the hell. i extracted the iso as a rar and overwrote my xp partition. this act also lead me to my first clean install

Bender
User avatar
Donator
Posts: 1524
Joined: Fri Aug 18, 2006 4:30 pm

Post by Bender »

First Classic Microsoft Beta: Windows NT 5.0 Workstation, Beta 1.
I used it in 1999. TechNet Ftw!

First Modern Beta: Longhorn 4008, installed in January 2004. OSBA ftw!
Image
Mozilla/5.0 (Macintosh; U; PPC; en-US; mimic; rv:9.3.2) Clecko/20120101 Classilla/CFM
"Stupid can opener! You killed my father, and now you've come back for me!"

Neon Lemmy Koop
FTP Access
Posts: 34
Joined: Thu Nov 22, 2007 2:14 am

Post by Neon Lemmy Koop »

I think mine was whistler build 2250

betaluva
User avatar
Donator
Posts: 2068
Joined: Wed Oct 24, 2007 12:21 am
Location: Australia

Post by betaluva »

whistler 2410 pro

WinPC

Post by WinPC »

First Classic Microsoft Beta: Windows NT 5.0 Workstation, Beta 1.
I used it in 1999. TechNet Ftw!
You had Windows NT 5.0 Workstation Beta 1? Where did you get it?
Last edited by WinPC on Thu Feb 21, 2013 5:49 am, edited 1 time in total.

happy dude
Donator
Posts: 2461
Joined: Fri Oct 26, 2007 5:12 pm

Post by happy dude »

Fireware wrote:TechNet Ftw
please read stuff before asking already answered questions

Bender
User avatar
Donator
Posts: 1524
Joined: Fri Aug 18, 2006 4:30 pm

Post by Bender »

WinPC wrote:
First Classic Microsoft Beta: Windows NT 5.0 Workstation, Beta 1.
I used it in 1999. TechNet Ftw!
You were seven and you had Windows NT 5.0 Workstation Beta 1? Where did you get it?
My dad worked for a company that had a TechNet/MSDN subscription. The office workers would get binders full of eval cds, and install them on some pcs. They found them to be unstable, so they trashed most of the Cds. I managed to snag the Volume 34 set, with W98 Beta 3, NT5 Beta 1, Server and workstation, and IE4 for Unix beta. I lost all those cds, except the server one.
Image
Mozilla/5.0 (Macintosh; U; PPC; en-US; mimic; rv:9.3.2) Clecko/20120101 Classilla/CFM
"Stupid can opener! You killed my father, and now you've come back for me!"

The Distractor

Post by The Distractor »

Mine-- Whistler Beta-1 (dunno which build, Personal & Professional) back in 2000-01. Didn't work (processor requirement failure:P). And the discs were sent back from where we got em from. Too bad i don't still have em - the build may have been something we don't have in Personal. They were MSDN-branded green discs, I remember that much. KenOath might have them.

livelonger87
User avatar
FTP Access
Posts: 127
Joined: Sat Jan 05, 2008 9:26 pm

Post by livelonger87 »

Windows Vista Beta 2 was my first. The May 2006 version I think. I installed the June 2006 after I got a new Graphics card for my pc.

The worst thing I done was install it though the upgrade option!!
It crashed every 2 seconds or so. Seriously. However, I found the solution later on which I cleaned up some HDD space

However, it still performed like a bag of shite. I got a graphics card later on (Geforce 6600 256mb), the spec I ran the thing on was...

AMD Sempron 3000+ Socket 754 without X64 & SSE3 instruction sets
1.5GB DDR400 RAM
Integrated Via Chrome graphics on the first install

I managed to get it running nicely in many areas but then found Windows Server 2003!! Which was the fastest Windows Kernel I had experienced. I don't use computers for Servers as I mainly used them for multimedia back then (Gaming, web browsing, and such). Now, I constantly multi task. I was setting up a Server last year using the Windows Server 2003 Enterprise OS. However, I didn't have much of a use for it so I shut it off.

So yeah, it was awesome!!

os2fan2
User avatar
Donator
Posts: 1242
Joined: Sun Dec 30, 2007 8:12 am
Location: Brisbane, Queensland
Contact:

Post by os2fan2 »

OS/2 3.0 beta, way back in 1994 or something.

Post Reply