Page 1 of 1

WinRAR 3.70 beta 6 - Compatible with Windows Vista!

Posted: Sat Apr 07, 2007 7:26 pm
by Oleg-A
If you are a Windows Vista user, maybe you tried to install WinRAR 3.6x. The 3.6x builds are not compatible with Vista.
But they released 3.70 beta 6, which compatible with the newest operating system!
Download it now:
WinRAR 3.70 beta 6 (1,17 MB)
http://rarlab.com/rar/wrar37b6.exe
RAR 3.70 beta 1 (for DOS) (0,64 MB)
http://rarlab.com/rar/rarx37b1.exe
Other beta 6 - localized versions
Can be found there: http://rarlab.com/download.htm

Posted: Sun Apr 08, 2007 10:34 am
by rws7
thx for informing me about this. I should be getting Vista Upgrade kit within a month.

Posted: Mon Apr 09, 2007 2:01 pm
by Evan
I can't believe windows created something thats not fully backwards compatible with older software. Do they want to loose money?

Posted: Mon Apr 09, 2007 11:51 pm
by Oleg-A
Most of all the older software compatible with Vista, but there are some exclusions, for ex. WinRAR and Nero (<7.7.x.x versions)

Posted: Mon Apr 09, 2007 11:59 pm
by ppc_digger
Evan wrote:I can't believe windows created something thats not fully backwards compatible with older software. Do they want to loose money?
Are you kidding? Where were you during the XP transition? Almost everybody had stuff incompatible with it.

Posted: Tue Apr 10, 2007 2:10 am
by empireum
ppc_digger wrote:
Evan wrote:I can't believe windows created something thats not fully backwards compatible with older software. Do they want to loose money?
Are you kidding? Where were you during the XP transition? Almost everybody had stuff incompatible with it.
Maybe he meant it as a joke I remember these times (unfortunately), I had tons of incompatibilities...

Posted: Tue Apr 10, 2007 8:21 pm
by Evan
And i hated XP just as much during that time. Seriously how hard is it to create to separate runtimes rather then moulding a new one.

Posted: Tue Apr 10, 2007 8:38 pm
by .UU
I'm using WinRAR 3.50 with Vista fine.

Posted: Wed Apr 25, 2007 9:27 pm
by tristan
all winrar versions worked fine for me on vista (even of beta builds of vista)

Posted: Thu Apr 26, 2007 6:11 am
by ddrmaxromance
They still make updates for MS-DOS?!