BetaArchive
https://www.betaarchive.com/forum/

Wiki's MediaWiki version is not latest
https://www.betaarchive.com/forum/viewtopic.php?f=13&t=40041
Page 1 of 1

Author:  MCpillager12 [ Thu Jul 04, 2019 1:57 pm ]
Post subject:  Wiki's MediaWiki version is not latest

Title says it all.
Version is 1.32, while latest is 1.33.

Author:  x010 [ Thu Jul 04, 2019 10:22 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

1.32 is still supported, and I see no major need for us (looking at the release notes) to upgrade at this time. While being in the latest version is nice, the admins here are busy, and I don't think it is required right now.

Author:  JonathonWyble [ Fri Jul 05, 2019 7:14 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

MCpillager12 wrote:
Title says it all.
Version is 1.32, while latest is 1.33.

Offtopic Comment
Coming from the person who doesn't want to upgrade their operating system (staring at you, MCpillager12) *hehe* Just kidding.

Anyway, you do not always have to upgrade your wiki software version (or any website software) every time a new version comes out. They'll upgrade their MediaWiki software when the time is right.

Author:  MCpillager12 [ Sat Jul 06, 2019 10:43 am ]
Post subject:  Re: Wiki's MediaWiki version is not latest

x010 wrote:
1.32 is still supported, and I see no major need for us (looking at the release notes) to upgrade at this time. While being in the latest version is nice, the admins here are busy, and I don't think it is required right now.

There are some changes:
Image
Basically, you can block a user from editing or creating accounts.

Author:  AlphaBeta [ Sat Jul 06, 2019 12:19 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

Blocks are hardly a new feature, unless you mean that you can block an IP from creating accounts only, without blocking editing as well.

Author:  MCpillager12 [ Sat Jul 06, 2019 12:57 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

I meant that you can block an IP or user from creating accounts only, without blocking editing.

Author:  x010 [ Mon Jul 08, 2019 10:33 am ]
Post subject:  Re: Wiki's MediaWiki version is not latest

AlphaBeta wrote:
Blocks are hardly a new feature, unless you mean that you can block an IP from creating accounts only, without blocking editing as well.

He's referring to the introduction of partial blocks (https://www.mediawiki.org/wiki/Manual:Block_and_unblock). Again, while that's a nice feature to have, it's not a reason to upgrade by itself.

Author:  YueLing11 [ Tue Jul 09, 2019 1:44 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

Also the latest MediaWiki version support visual editing. It should be upgraded.

Author:  x010 [ Tue Jul 09, 2019 3:54 pm ]
Post subject:  Re: Wiki's MediaWiki version is not latest

YueLing11 wrote:
Also the latest MediaWiki version support visual editing. It should be upgraded.

VisualEditor (https://www.mediawiki.org/wiki/VisualEditor) is not bundled-in with any MediaWiki release (even 1.33), and it has been around for some time. While I personally would like VisualEditor to be made available for this wiki, Andy has refused to install it citing its complexity (which is true unfortunately).

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/