BetaArchive Logo
Navigation Home Screenshots Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 22d, 1h, 7m | CPU: 24% | MEM: 5446MB of 10797MB used
{The community for beta collectors}

Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 12 posts ] 
Author Message
 PostPost subject: Screenshot Gallery Update        Posted: Sun Aug 17, 2008 11:10 pm 
Administrator
User avatar
Offline

Joined
Fri Aug 18, 2006 11:47 am

Posts
12473

Location
Merseyside, United Kingdom

Favourite OS
Microsoft Windows 7 Ultimate x64
Hello all,

After some small issues with the screenshots gallery, it has now been fixed. In addition to that the thumbnail script has also been updated to including 'caching'. This takes the load off the server since it only has to be cached once, then the thumbnail is stored. However, since it only caches once its been viewed, some pages may be slower than others when you view them, since you might be the first visitor to the page since the update. Hopefully, eventually, every page will be cached for fastest viewing experience.

As always with updates if you find an issue let me know asap.

Andy (Admin)

_________________
Image

BetaArchive Discord: https://discord.gg/epK3r6A


Top  Profile  WWW
 PostPost subject:        Posted: Mon Aug 18, 2008 1:54 am 
Donator
Offline

Joined
Sat May 24, 2008 10:05 am

Posts
2045
There seems to be a small problem with the galleries for longhorn builds 4039 and 5112.
In 4039 half the images display as that hortible little box with a red x in it, and in 5112 two of the images get a strange "Not an image file" error.
Great work on the thumbnail caching btw, i'll visit as many of the pages as I can so that other people arent the first to view since the update.


Top  Profile
 PostPost subject:        Posted: Mon Aug 18, 2008 8:25 am 
Administrator
User avatar
Offline

Joined
Fri Aug 18, 2006 11:47 am

Posts
12473

Location
Merseyside, United Kingdom

Favourite OS
Microsoft Windows 7 Ultimate x64
The images are either broken (first one) or there is a special character in the name (second one). I'll try and remember to fix the name one and delete the bad ones when I get time.

_________________
Image

BetaArchive Discord: https://discord.gg/epK3r6A


Top  Profile  WWW
 PostPost subject:        Posted: Mon Aug 18, 2008 6:24 pm 
jabster wrote:
There seems to be a small problem with the galleries for longhorn builds 4039 and 5112.
In 4039 half the images display as that hortible little box with a red x in it, and in 5112 two of the images get a strange "Not an image file" error.
Great work on the thumbnail caching btw, i'll visit as many of the pages as I can so that other people arent the first to view since the update.

I took a look in those folders a while back when feeling the need to do a cleanup,
& noticed that most of the files were 2.7+mb in size, not sure if the rules permitted
such large files, I thought half or 1 mb was the preferred file size for pictures...
Why someone would up 20-30mb of screens is odd...
I try to keep mine down below 300k a piece...


Top
 PostPost subject:        Posted: Mon Aug 18, 2008 10:39 pm 
Donator
Offline

Joined
Sat May 24, 2008 10:05 am

Posts
2045
:oops:
I actually believe that is my fault, sorry.
I just quickly saved the images as png's using mspaint, instead of irfanview like I normally use, and didn't realise they were such a rediculous size until after i'd sent them to andy.
Sorry about that.


Top  Profile
 PostPost subject:        Posted: Tue Aug 19, 2008 2:24 pm 
I just downloaded some of the 4039 screens you upped, they're actually 4mb in size,
& corrupt, I tried to open them with ACDSee, MS Photo Editor & MS Paint, Only paint
would open them, & it showed they were corrupt, so they'll have to be deleted...

Here's one of them opened in paint...
Image


Top
 PostPost subject:        Posted: Tue Aug 19, 2008 2:45 pm 
Donator
Offline

Joined
Sat May 24, 2008 10:05 am

Posts
2045
yeah, sorry about that.
Perhaps there is a problem with mspaint in build 4039, because it just makes no sense that a 1280x1024 image in png format would be larger than a bitmap. Tommorow i'll install 4039 on my spare partition, check it out, and take replacement screens.


Top  Profile
 PostPost subject:        Posted: Tue Aug 19, 2008 3:04 pm 
Donator
Offline

Joined
Sat Feb 24, 2007 4:14 pm

Posts
6612

Location
United Kingdom

Favourite OS
Server 2012 R2
jabster wrote:
yeah, sorry about that.
Perhaps there is a problem with mspaint in build 4039, because it just makes no sense that a 1280x1024 image in png format would be larger than a bitmap. Tommorow i'll install 4039 on my spare partition, check it out, and take replacement screens.


Paint has always produced rather large PNGs for some reason :(

_________________
BuildFeed - the ultimate collaborative NT build list - Windows Longhorn - a look at a defining Microsoft project


Top  Profile  WWW
 PostPost subject:        Posted: Tue Aug 19, 2008 10:35 pm 
Administrator
User avatar
Offline

Joined
Fri Aug 18, 2006 11:47 am

Posts
12473

Location
Merseyside, United Kingdom

Favourite OS
Microsoft Windows 7 Ultimate x64
craig wrote:
hounsell wrote:
Paint has always produced rather large PNGs for some reason :(


because its crap?


I wouldn't say crap, just not optimised. Vista's paint saves them quite well :)

_________________
Image

BetaArchive Discord: https://discord.gg/epK3r6A


Top  Profile  WWW
 PostPost subject:        Posted: Tue Aug 19, 2008 10:36 pm 
FTP Access
User avatar
Offline

Joined
Wed Aug 30, 2006 10:06 pm

Posts
2393
Andy wrote:
I wouldn't say crap, just not optimised.

Have you ever seen the Jpeg's that Paint saves? Yuck! :P

_________________
Image


Top  Profile
 PostPost subject:        Posted: Tue Aug 19, 2008 10:45 pm 
Administrator
User avatar
Offline

Joined
Fri Aug 18, 2006 11:47 am

Posts
12473

Location
Merseyside, United Kingdom

Favourite OS
Microsoft Windows 7 Ultimate x64
Vista Ultimate R2 wrote:
Andy wrote:
I wouldn't say crap, just not optimised.

Have you ever seen the Jpeg's that Paint saves? Yuck! :P


Paint in Vista does them a hell of a lot better than XP does, thats for sure. At least Vista's doesn't make it pixelised and look like its got 1% quality etc.

_________________
Image

BetaArchive Discord: https://discord.gg/epK3r6A


Top  Profile  WWW
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 12 posts ] 




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2018

 

Sitemap | XML | RSS