Page 1 of 1

Can't run Win32s 1.25

Posted: Sat Aug 17, 2019 3:19 pm
by vlad557776
Hello.

Recently I wanted to install a copy of Claris Impact 2.0, but I need Win32s to do it. They installed, but, when I try to run FreeCell (the sample application), it gives me "Unexpected DOS error: 21". I tried everything I could find on the net - the only thing I accomplihed was remove that annoying MS Office toolbar (not linked to my Win32s problem). I'm using Windows for Workgroups 3.11 and DOS 7.1. The only thing I couldn't make to work (which can fix my problem) was create a permament swapfile (Damn you, DOS 7.1).

Please help!

Re: Can't run Win32s 1.25

Posted: Sat Aug 17, 2019 3:35 pm
by MCpillager12
Use DOS 6.22. Also what emulator are u using?

Re: Can't run Win32s 1.25

Posted: Sat Aug 17, 2019 6:18 pm
by vlad557776
I'm using VirtualBox 6.0.10 r132072. Going to install DOS 6.22, Windows for Workgroups 3.11 and these Win32s and write back.

Re: Can't run Win32s 1.25

Posted: Sat Aug 17, 2019 6:49 pm
by vlad557776
I tried. Still the same problem.

Re: Can't run Win32s 1.25

Posted: Sat Aug 17, 2019 7:21 pm
by ATeamInc
vlad557776 wrote:I tried. Still the same problem.
Try using an older/newer Win32s version. Or just use Windows 95.

Re: Can't run Win32s 1.25

Posted: Sun Aug 18, 2019 9:33 am
by MCpillager12
ATeamInc wrote:
vlad557776 wrote:I tried. Still the same problem.
Or just use Windows 95.
OP wants to use Windows 3.1, so let him.

You are using an unoptimized emulator for pre-9x.
Use 86Box/PCem/VARCem.

Re: Can't run Win32s 1.25

Posted: Sun Aug 18, 2019 2:03 pm
by Overdoze
It's not even an emulator, so it wouldn't surprise me if this is actually just another CPU issue. I think Win32s 1.30 or whatever the last version was also didn't work in Virtual PC for this reason.

Re: Can't run Win32s 1.25

Posted: Sun Aug 18, 2019 2:24 pm
by vlad557776
I think just like you, Overdoze (Damn you CPU and ACPI). Also, will Windows NT 3.1 Advanced Server work?