BetaArchive Logo
Navigation Home Database Screenshots Gallery Image Uploader Server Info FTP Servers Wiki Forum RSS Feed Rules Please Donate
UP: 7d, 6h, 17m | CPU: 37% | MEM: 5828MB of 12279MB used
{The community for beta collectors}

Post new topic Reply to topic  [ 11 posts ] 
Author Message
 PostPost subject: Windows 95 Preliminary Release Problems in 86Box        Posted: Sun Apr 28, 2019 11:26 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Jul 12, 2017 6:23 am

Posts
54

Location
Earth

Favourite OS
Windows 95, 2000, XP, 7, and 10
I am trying to install a Preliminary Release build of Windows 95 (Chicago) such as 58s, 73f, or 73g in 86Box. The installation and first boot for all three builds work just fine (fdisk and format C: with a Windows 95 boot disk, run setup from CD, accept all default settings, create autoexec.bat and config.sys on C: drive, reboot with boot disk still in, change both "Buffers" and "Files" from 30 to 90, and reboot to Windows), but at the second boot, it either hangs at the boot screen or gives me this error (screenshot from 73g):

Image

And then by the third boot, I get this error (screenshot from 73g):

Image

After this happens, all of the contents of the C:\CHICAGO are completely glitched and broken (screenshot from 73g):

Image

Is there something I am doing wrong? Does anyone else get these errors? Does anyone know a fix?

My specs are:
Award 430VX PCI, Pentium 120, 128MB RAM, S3 Trio64 (VLB), PS/2 Mouse, Sound Blaster 16

Thanks.


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Sun Apr 28, 2019 11:37 pm 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Feb 24, 2014 10:28 am

Posts
1577

Location
Slovenia

Favourite OS
5111
I would reduce the ram to 16 MB or so. That was a lot when these builds were made, 128 MB might be an overkill.

_________________
Image

KRNL386 - my site about retro computing | My site about Windows 1.0 | My blog | 86Box Manager - my configuration manager for 86Box


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Sun Apr 28, 2019 11:39 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2000

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
How are you rebooting? Soft reset or hard reset?

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Mon Apr 29, 2019 5:24 pm 
Reply with quote
Donator
User avatar
Offline

Joined
Wed Jun 22, 2011 10:27 am

Posts
434

Location
Croatia

Favourite OS
5.0.2195
I'd bet this is a hard drive issue... Are you using a drive bigger than 2GB? I think the Win95 OSR2 bootdisk formats to FAT32... try a DOS5/6 bootdisk with CD-ROM drivers and try dropping the HDD size down to around 540MB (that's the LBA limit for old motherboards).

_________________
This signature has seen better days, for sure...


Top  Profile  WWW
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Tue Apr 30, 2019 12:15 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Jul 12, 2017 6:23 am

Posts
54

Location
Earth

Favourite OS
Windows 95, 2000, XP, 7, and 10
Battler wrote:
How are you rebooting? Soft reset or hard reset?

Hard reset.

Zv45Beta wrote:
Are you using a drive bigger than 2GB? I think the Win95 OSR2 bootdisk formats to FAT32...

The disk is exactly 2GB (2048MB) and I am using a Win95 OSR1 bootdisk.

Overdoze wrote:
I would reduce the ram to 16 MB or so. That was a lot when these builds were made, 128 MB might be an overkill.

This does not work.

Strangely I don't think I have ever had this happen to me on Virtual PC. :(


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Tue Apr 30, 2019 2:27 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Nov 22, 2017 5:39 pm

Posts
176

Location
Somewhere in QEMU

Favourite OS
Millennium 2358, Longhorn 3713
I actually noticed this when installing 73g on PCem once. I recommend using a 386 BIOS with an AMD processor and 9MB RAM. I also prefer a Trident graphics card if you want 256 color and 1024x768 resolution and SB1 if you want sound. After setup, if it hangs at the boot screen, then hard reset, hold F8 during the boot and then run through Y on everything until you reach win.com; select N on it. Then browse to the CHICAGO directory and try using "win.com /3 /b".

_________________
Image

BetaWiki contributor.


Top  Profile  WWW
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Tue Apr 30, 2019 5:23 am 
Reply with quote
Donator
User avatar
Offline

Joined
Sat Aug 19, 2006 8:13 am

Posts
2000

Location
Slovenia, Central Europe.

Favourite OS
Windows 98 SE 4.10.2222B
I think the hard disk is too big, and you should install from MS-DOS rather than from Windows 95 OSR 2. My install of Chicago 58s, for example, was done from MS-DOS 6.00 onto a hard disk smaller than 503 MB, and this issue didn't happen.

_________________
Join #softhistory @ RoL IRC, a nice community for true enthusiasts!
Anime channel: #doki-doki @ RoL IRC, Mibbit, KiwiIRC.
The 86Box help channel is #softhistory now!

Check out our SoftHistory Forum for quality discussion about older software.


Top  Profile  WWW  ICQ  YIM
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Tue Apr 30, 2019 9:40 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Feb 24, 2014 10:28 am

Posts
1577

Location
Slovenia

Favourite OS
5111
Battler wrote:
I think the hard disk is too big, and you should install from MS-DOS rather than from Windows 95 OSR 2. My install of Chicago 58s, for example, was done from MS-DOS 6.00 onto a hard disk smaller than 503 MB, and this issue didn't happen.


He said he's using an OSR1 disk, so FAT16 is the only option in that case anyway.

_________________
Image

KRNL386 - my site about retro computing | My site about Windows 1.0 | My blog | 86Box Manager - my configuration manager for 86Box


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Sat May 04, 2019 5:39 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Wed Jul 12, 2017 6:23 am

Posts
54

Location
Earth

Favourite OS
Windows 95, 2000, XP, 7, and 10
I managed to get build 73g working with my original specs.

After booting to the OS for the first time and then shutting it down, I extracted the C:\CHICAGO directory from the disk image using 7-Zip, rebooted until the files were corrupted, and then ran SCANDISK from the Windows 95 boot disk. SCANDISK seemed to fix the corruption, after which I moved my extracted C:\CHICAGO directory back onto the image. Now it boots just fine.

I cannot figure out how to do this with build 58s because when I open the disk image in 7-Zip, it only shows two files with the extension .fat corresponding to the file system (NTFS disks do this too), and after another reboot, I can see all the files again but only after the C:\CHICAGO directory is corrupted. However, I think I will stick with build 73g since the Sound Blaster 16 and S3 drivers work for me on this build.


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Sat May 04, 2019 8:49 am 
Reply with quote
FTP Access
User avatar
Offline

Joined
Mon Feb 24, 2014 10:28 am

Posts
1577

Location
Slovenia

Favourite OS
5111
SupernovaNick wrote:
I managed to get build 73g working with my original specs.

After booting to the OS for the first time and then shutting it down, I extracted the C:\CHICAGO directory from the disk image using 7-Zip, rebooted until the files were corrupted, and then ran SCANDISK from the Windows 95 boot disk. SCANDISK seemed to fix the corruption, after which I moved my extracted C:\CHICAGO directory back onto the image. Now it boots just fine.

I cannot figure out how to do this with build 58s because when I open the disk image in 7-Zip, it only shows two files with the extension .fat corresponding to the file system (NTFS disks do this too), and after another reboot, I can see all the files again but only after the C:\CHICAGO directory is corrupted. However, I think I will stick with build 73g since the Sound Blaster 16 and S3 drivers work for me on this build.


This is a very interesting issue, so if you could upload your 86Box config file and the disk image you're using, maybe we could figure this out.

_________________
Image

KRNL386 - my site about retro computing | My site about Windows 1.0 | My blog | 86Box Manager - my configuration manager for 86Box


Top  Profile
 PostPost subject: Re: Windows 95 Preliminary Release Problems in 86Box        Posted: Sat May 04, 2019 9:01 am 
Reply with quote
FTP Access
Offline

Joined
Sat Oct 20, 2018 11:37 am

Posts
456
For all 58s installs I had, you can only see FAT files using 7-zip. WinImage can open the disk fine so use WinImage. I haven't had any trouble installing those releases in 86Box.


Top  Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All views expressed in these forums are those of the author and do not necessarily represent the views of the BetaArchive site owner.

Powered by phpBB® Forum Software © phpBB Group

Copyright © 2006-2019

 

Sitemap | XML | RSS